ТвойWeb » » Тестовые версии ExBB Full Mods и модулей » ExBB FM 1.0 Beta

Страниц (31): В начало « ... 6 7 8 9 [10] 11 12 13 14 ... » В конец
 

91. TvoyWeb - 30 Июля, 2007 - 12:23:05 - перейти к сообщению
TitiS пишет:
Пришлось выкручиваться TAB'ом чтобы создать администратора...

Дык табом же удобнее, я всегда им пользуюсь.
TitiS пишет:
Включил все моды. Теперь на каждой странице форума такие вот предупреждения:

Спасибо за баг исправил, просто во время инсталяции эта переменная не прописывалась в данные пользователя.
SlyFox пишет:
закомментируй всё, кроме E_ALL, таким образом

Не надо ничего комментировать. Я специально сделал так и пытаюсь добиться чтобы форум работал совсем без каких либо ошибок. К тому же это помогает найти баги.
Roler пишет:
В сообщениях форума, надпись [Script Execution time: 0.0305] налезает на верхние, InvisionExBB Style converted by Markus® и т.д.
Не могу сменить скин через админку, всё равно остаётся таким же. Сменил в профиле - никакого эффекта.

Покажи где у тебя налезает, ссылку дай.
Насчет смены скина: с форумом поставляется только один скин, скины старых версий форума не подойдут. Как у тебя оказалось что ты можешь выбрать другой скин?
Насколько я знаю под эту версию еще никто не переделывал скины.
Vlad Tepes
Попробую разобраться.
92. TvoyWeb - 30 Июля, 2007 - 12:57:34 - перейти к сообщению
Vlad Tepes
Замени функцию в vars.class.php
CODE:
function Clean_Value($var) {
$var = (get_magic_quotes_gpc()) ? trim(stripslashes($var)):trim($var);
$var = preg_replace("#\r#","",$var);
return preg_replace("#&(\#[0-9]+;)#", "&$1", htmlspecialchars($var,ENT_QUOTES));
}


Архив обновлен.
93. Vlad Tepes - 30 Июля, 2007 - 15:14:06 - перейти к сообщению
Перезалил папку include из нового архива. Перестало работать отобразить последнее сообщение темы. Пишет "Подождите идет загрузка" и все.
94. Vlad Tepes - 30 Июля, 2007 - 15:45:28 - перейти к сообщению
А в FM 1 уже нельзя админам html использовать?
95. Roler - 30 Июля, 2007 - 15:48:19 - перейти к сообщению
TvoyWeb
Я свой скин сделать хотел, скопировал InvisionExBB, переименовал, но не переключается на него
В boardinfo.php прописано правильно, тот который я выбрал
Где налезает, показать не могу, форум на локали тестирую.
96. Нежельский - 30 Июля, 2007 - 16:22:16 - перейти к сообщению
Установлен PHP v5.2.3 на IIS6.0 на сервере локальной сети.
Установил ExBB FM 1.0. Получил
Цитата:
Notice: Undefined index: PATH in c:\Inetpub\wwwroot\forums\include\fm.class.php on line 412

страницы форума отображаются. Зашел по ссылке Админцентр, ввел пароль, получаю
Цитата:
Ошибка CGI
Указанное приложение CGI не возвратило полный набор заголовков HTTP.


После исправления в fm.class.php строка 426, а также в admincenter.php строка 39 параметра 'PATH' на 'Path':
CODE:
if (preg_match('/[c-z]:\\\.*/i', $_SERVER['PATH'])) return;

на
CODE:
if (preg_match('/[c-z]:\\\.*/i', $_SERVER['Path'])) return;

ошибки исчезли.

В админцентре отключил личные сообщения и теперь при входе на форум нового пользователя он получает окошко с сообщением о личном сообщении. Кнопкой Да получает Служба личных сообщений отключена!
Кнопка Нет подвешивает страничку и в статусной строке браузера пишет Ошибка!

И ещё, в нашей локальной сети нет почты, но регистрация нового пользователя упорно требует e-mail даже если в конфигурации форума выключена опция "Включить функции электронной почты на конференции?"!
Нельзя ли при отключенной почте не требовать при регистрации нового пользователя его e-mail?
97. TvoyWeb - 30 Июля, 2007 - 22:47:46 - перейти к сообщению
Vlad Tepes пишет:
Перезалил папку include из нового архива. Перестало работать отобразить последнее сообщение темы. Пишет "Подождите идет загрузка" и все.

Странно, все проверил у меня все пашет.
Vlad Tepes пишет:
А в FM 1 уже нельзя админам html использовать?

Почему нельзя? При ответе есть выбор использовать HTML или нет.
Roler
Я исправил. Спасибо за баг.
Скрин твой удалил, сервак на котором картинка виснет в итоге страница не грузится.
Нежельский пишет:
Notice: Undefined index: PATH

Скорее всего это сервак так отдает перменную. Счас пол нета облазил не нашел, чтобы эта переменная окружения писалась именно так.
Личные сообщения исправил. Не было проверки на отключение ЛС.
С емаил функцией тоже разобрался, тоже не было проверки на отключение функции.

Все исправления в архиве. Извините что не выкладываю обновления отдельным архивом.
98. Нежельский - 31 Июля, 2007 - 10:43:31 - перейти к сообщению
TvoyWeb
Спасибо за оперативное исправление!
Вылез другой баг.
При отключенной почте после регистрации первого пользователя второму пользователя отказыевает в регистрации сообщая: "Такой адрес email уже зарегистрирован! ", т.е. обнаружен второй пустой емейл.

Ещё просьба, доработать формирование контента странички "Условия использования конференции" в соответствии с конфигурацией конференции, а то там много чего написано, а у меня простая форма регистрации без емайлов! да и про часовой пояс писать мне никчему! Или хотя бы подскажите в каком файле это можно исправить.
99. Vlad Tepes - 31 Июля, 2007 - 10:49:08 - перейти к сообщению
TvoyWeb пишет:
При ответе есть выбор использовать HTML или нет.

А все, теперь понял. Просто при обновлении те посты, где уже использовался html показываются в виде кода. Теперь придется каждый редактировать, чтобы поставить галочку
100. TvoyWeb - 31 Июля, 2007 - 14:36:30 - перейти к сообщению
Нежельский
Исправил. Обновление в архиве. Из архива достаточно заменить файл register.php.
Насчет правил смотрите в папке скина language/russian/lang_front_help_rules.php

Форум на AlfaSpace.NET


Powered by ExBB
ExBB FM 1.0 RC1 by TvoyWeb.ru
InvisionExBB Style converted by Markus®

[Script Execution time: 0.02]     [ Gzipped ]