Strict Standards: Resource ID#18 used as offset, casting to integer (18) in /home/u1001/domains/tvoyweb.ru/public_html/forums/include/fm.class.php on line 401

Strict Standards: Resource ID#24 used as offset, casting to integer (24) in /home/u1001/domains/tvoyweb.ru/public_html/forums/include/fm.class.php on line 401

Strict Standards: Resource ID#26 used as offset, casting to integer (26) in /home/u1001/domains/tvoyweb.ru/public_html/forums/include/fm.class.php on line 401

Strict Standards: Resource ID#27 used as offset, casting to integer (27) in /home/u1001/domains/tvoyweb.ru/public_html/forums/include/fm.class.php on line 401
ТвойWeb :: ExBB FM 1.0 Beta [25]
ТвойWeb ТвойWeb
Качественный Европейский хостинг
Форум для чайников
 Чат на форуме      Помощь      Поиск      Пользователи


 Страниц (31): В начало « ... 21 22 23 24 [25] 26 27 28 29 ... » В конец  

> Описание: тестируем
sank
Отправлено: 03 Сентября, 2007 - 10:51:33
Post Id



Newbie


Покинул форум
Сообщений всего: 15
Дата рег-ции: Авг. 2007  

Карма 0




потестил форум и пришел к выводу что лучше оставаться на 1.0 версии.
 
 Top
Lyosha-ha
Отправлено: 03 Сентября, 2007 - 16:55:17
Post Id


Newbie


Покинул форум
Сообщений всего: 9
Дата рег-ции: Март 2007  

Карма 0




yura3d, большое спасибо за помощь, пересчитал темы и теперь даты отображаются нормально.
 
 Top
Lyosha-ha
Отправлено: 03 Сентября, 2007 - 21:33:31
Post Id


Newbie


Покинул форум
Сообщений всего: 9
Дата рег-ции: Март 2007  

Карма 0




Я прям притягиваю глюки... =) Абсолютно не критичная ошибка, но интересно откуда она вылезла текст появляется при просмотре токо одной темы, текст:
CODE:
Notice: Undefined index: sig_on in ***\http\topic.php on line 380

380 Строчка в топих.пхп:
CODE:
'signature' => ($fm->exbb['sig'] === TRUE && $user['sig_on'] === TRUE && $user['sig'] != '') ? '<br><br>-----<br>'.$user['sig']:'',

Тема при этом отображается вполне коректно, но просто интересно почему так..

(Отредактировано автором: 03 Сентября, 2007 - 21:40:24)

 
 Top
yura3d
Отправлено: 03 Сентября, 2007 - 21:47:14
Post Id


Super Member


Покинул форум
Сообщений всего: 624
Дата рег-ции: Июль 2007  
Откуда: Минск, Беларусь

Карма 17




Lyosha-ha
В массиве с данными пользователя отсутствует элемент sig_on, значение этого элемента проверяется форумом при выдаче сообщений в теме. Дело в том что в старой версии форума, с которой Вы обновлялись, такого элемента в массиве не было. Очевидно конвертер этот момент не учитывает.
Чтобы исправить данный глюк зайдите в настройки Вашего профиля и напротив текста "Показывать Вашу подпись в сообщениях?" выберите "Да" или "Нет" (не важно что именно Вы выберите, главное чтобы один из вариантов был выбран). Потом сохраните профиль, параметр sig_on добавится в массив. Скорее всего ошибка сразу не исчезнет, ведь этот элемент должен быть и в данных других пользователей, соответственно и они должны обновить свой профиль.
Очень странно что этот недочёт вскрылся именно сейчас, до этого вроде проблем ни у кого не было
 
 Top
Lyosha-ha
Отправлено: 03 Сентября, 2007 - 23:04:12
Post Id


Newbie


Покинул форум
Сообщений всего: 9
Дата рег-ции: Март 2007  

Карма 0




yura3d, рискну предположить, что это из-за всего того же бага с установкой, а котором я писал чуть раньше, спасибо за оперативную помощь. И спасибо впринципе за это версию, она стала гораздо удобней предыдущей.
 
 Top
TvoyWeb Администратор
Отправлено: 04 Сентября, 2007 - 06:39:18
Post Id



Главный здесь


Покинул форум
Сообщений всего: 7072
Дата рег-ции: Нояб. 2003  
Откуда: Tashkent Uz

Карма 52




Lyosha-ha
Спасибо исправим.
yura3d пишет:
Очевидно конвертер этот момент не учитывает.

Было очевидно что этот параметр должен находиться в массиве юзера. Придется в конвертер засунуть массив с исходными данными пользователя.
 
 Top
TitiS
Отправлено: 04 Сентября, 2007 - 07:35:52
Post Id



Newbie


Покинул форум
Сообщений всего: 24
Дата рег-ции: Июль 2007  
Откуда: 127.0.0.1:80

Карма 0




Нужна помощь!

Вообщем решил обновить форум уже на сервере...
В течении обновления у меня была одна и та же ошибка (на одной странице её могло появляться несколько десятков) . В архиве:
update.jpg - одна из страниц с этой ошибкой
В конце обновления я наконец попав на форум опять увидел эту ошибку Недовольство, огорчение
forum.jpg

Вот не знаю что и делать. Проблема в функции chmod. Думаю о том, чтобы её вообще закомментировать
Скачать файл: update.rar
Скачан раз: 728
 
 Top
GN
Отправлено: 04 Сентября, 2007 - 08:43:42
Post Id



Junior Member


Покинул форум
Сообщений всего: 98
Дата рег-ции: Авг. 2006  
Откуда: Казахстан, Павлодар

Карма 2




TitiS пишет:
Вот не знаю что и делать. Проблема в функции chmod. Думаю о том, чтобы её вообще закомментировать
у меня такая же проблема была, я закомментировал include\fm.class.php 365 и 383 строку и проблема исчезла.
365 - /* chmod($filename,$this->exbb['ch_files']); */
383 - /* chmod($filename,$this->exbb['ch_files']); */
 
 Top
TvoyWeb Администратор
Отправлено: 04 Сентября, 2007 - 09:06:38
Post Id



Главный здесь


Покинул форум
Сообщений всего: 7072
Дата рег-ции: Нояб. 2003  
Откуда: Tashkent Uz

Карма 52




TitiS,GN
Похоже я знаю в чем проблема, но надо проверить.
GN, давай попробуем в аське разобраться. Ок?
 
 Top
TitiS
Отправлено: 04 Сентября, 2007 - 09:12:43
Post Id



Newbie


Покинул форум
Сообщений всего: 24
Дата рег-ции: Июль 2007  
Откуда: 127.0.0.1:80

Карма 0




GN вот я тож хотел закомментировать. Или даже просто сделать так:
CODE:

@chmod

Но вот... Это же не просто так Улыбка Вдруг в будущем из-за этого будут проблемы

TvoyWeb
Жду результатов... Всё таки заново восстанавливать (пока форум закрыт и ни кто ещё не постил) до версии 0.1.5 не хочется. 1.0 мне более понраву...


Да, кстати, ниче не буит если я в topic.php
CODE:

if ($fm->exbb['karma'] === TRUE){
$users[$user_id]['karma'] = (isset($user['karma'])) ? $user['karma']:0;
$users[$user_id]['karmalink'] = ($fm->user['id'] !== 0) ? $fm->LANG['Karma'].'<a href="#" onClick="Karma(\'plus\', '.$user_id.'); return false">'.$fm->LANG['KarmaAdd'].'</a>/<a href="#" onClick="Karma(\'minus\', '.$user_id.'); return false">'.$fm->LANG['KarmaDel'].'</a><br>':$fm->LANG['Karma'];
}

заменю на:
CODE:

if ($fm->exbb['karma'] === TRUE){
$users[$user_id]['karma'] = (isset($user['karma'])) ? $user['karma']:0;
$users[$user_id]['karmalink'] = ($fm->user['id'] !== 0) ? $fm->LANG['Karma'].'<a href="#" onClick="Karma(\'plus\', '.$user_id.'); return false">'.$fm->LANG['KarmaAdd'].'</a>/<a href="#" onClick="Karma(\'minus\', '.$user_id.'); return false">'.$fm->LANG['KarmaDel'].'</a><br>':$fm->LANG['Karma'];
if ($user_id==1)
{
$users[$user_id]['karma'] = '<b>откл.</b>';
$users[$user_id]['karmalink'] = '';
};
}

Улыбка Как всегда убираю себе карму...
Только когда я это сделал - у меня теперь вообще не отображается даже слова "Карма"... И ещё - после обновления HTML теги, которые я использовал в своих постах стали видны как есть

(Отредактировано автором: 04 Сентября, 2007 - 09:51:47)

 
 Top
Страниц (31): В начало « ... 21 22 23 24 [25] 26 27 28 29 ... » В конец
Сейчас эту тему просматривают: 1 (гостей: 1, зарегистрированных: 0, скрытых: 0)
« Тестовые версии ExBB Full Mods и модулей »


Все гости форума могут просматривать этот раздел.
Только администраторы и модераторы могут создавать новые темы в этом разделе.
Только администраторы и модераторы могут отвечать на сообщения в этом разделе.



Форум на AlfaSpace.NET


Powered by ExBB
ExBB FM 1.0 RC1 by TvoyWeb.ru
InvisionExBB Style converted by Markus®

[Script Execution time: 0.0125]     [ Gzipped ]



Notice: ob_end_flush(): failed to send buffer of ob_gzhandler (1) in /home/u1001/domains/tvoyweb.ru/public_html/forums/include/page_tail.php on line 33